الغـــــلاف

الإهداء >


الإهـــــــــداء

أســرار المجــاهدين
للـتـراســل الآمــــن عبـر الشبـكــات
الإهـــــــــداء

الحمد لله معزّ المؤمنين ومذل المشركين. الحمد لله وحده. نصر عباده ، وأعز جنده ، وهزم الأحزاب وحده . الحمد لله والصلاة والسلام على عبده ورسوله إمام المجاهدين وقائد الغر المحجلين نبي الرحمة والملحمة المبعوث بالسيف بين يدي الساعة حتى يعبد الله وحده لا شريك له فصلوات الله وسلامه عليه وعلى آله وصحبه الغر الميامين ومن تبعهم بإحسان إلى يوم الدين.
أما بعد .

هذا البرنامج إهداء إلى الذين رفعوا عاليا رأس الأمة أمام جنود الشيطان من يهود و صليبيين و من حالفهم و من روافض حاقدين على الإسلام و المسلمين. إلى أحفاد الصحابة رُضوان الله عليهم الذين أطفأوا نار المجوس. إلى الذين يقاتلون لتكون كلمة الله هي العليا و كلمة الذين كفروا السفلى. إلى المجاميع الجهادية في جميع أنحاء العالم و نخص بالذكر:

دولة العــراق الإســــلامية
جماعة أنصـــار الإســـــلام
تنــظيـــم قاعــدة الجــــهاد
إمـارة أفغانستان الإسلامية
إمـارة القــــوقاز الإسـلامية

{يَا أَيُّهَا النَّبِيُّ حَرِّضِ الْمُؤْمِنِينَ عَلَى الْقِتَالِ إِن يَكُن مِّنكُمْ عِشْرُونَ صَابِرُونَ يَغْلِبُواْ مِئَتَيْنِ وَإِن يَكُن مِّنكُم مِّئَةٌ يَغْلِبُواْ أَلْفاً مِّنَ الَّذِينَ كَفَرُواْ بِأَنَّهُمْ قَوْمٌ لاَّ يَفْقَهُونَ } الأنفال- 65
و آخر دعوانا أن الحمد لله رب العالمين

إهداء إلى المجاهدين عامة و إلى دولة العراق الإسلامية خاصة


منتديات التوزيع المعتمدة

منتديات التوزيع المعتمدة

هذا البرنامج إصدار خاص من
((شبكة الإخلاص الإسلامية))

يوزع حصرياً على المنتديات الجهادية التالية

((الإخلاص)) ((الحسـبة)) ((البـراق)) ((الفردوس))

الإصدار الأول من برنامج "أسرار المجاهدين" قام بنشره الإخوة في الجبهة الإعلامية الإسلامية العالمية و قد سجلوا بذلك سبقا نوعيا في مجال الإعلام الجهادي. و استمرارا على نهج دعم الإعلام الجهادي قامت مجموعة الأمن التقني في شبكة الإخلاص الإسلامية بتطوير البرنامج و إصدار هذه النسخة الخاصة دعما للمجاهدين عامة و دولة العراق الإسلامية خاصة. و إذ نتقدم بالشكر لكل من ساهم في هذا الإنجاز المميز فإننا نؤكد أن هذا العمل هو أساسُ لنصرة الإخوة من أهل الثغور و تقربا إلى الله تعالى أولا و أخيرا.

((قُلْ إِنَّ صَلاَتِي وَنُسُكِي وَمَحْيَايَ وَمَمَاتِي لِلّهِ رَبِّ الْعَالَمِينَ{162} لاَ شَرِيكَ لَهُ وَبِذَلِكَ أُمِرْتُ وَأَنَاْ أَوَّلُ الْمُسْلِمِينَ))

جميع روابط شبكة الإخلاص الإسلامية:

1. روابط عادية.

http://aekhlaas.net/forum /

http://aekhlaas.com/forum /

http://alekhlaas.net/forum

http://ekhlaas.ws/forum/

http://ekhlaas.info/forum/

http://al-ekhlaas.net/forum/

http://ekhlaas.org/forum/

http://al-ekhlaas.org/forum/

http://alekhlaas.info/forum/

http://www.ek-ls.org/forum/

http://www.alekhlaas.org/forum/

2. روابط مشفرة.

https://ekhlaas.org/forum/

https://aekhlaas.net/forum/

https://aekhlaas.com/forum/

https://alekhlaas.info/forum /

ملاحظة: يتم التأكد من أصالة النسخة عن طريق البصمة الرقمية 256 بت المرفقة أو عن طريق ملف الإمضاء الرقمي المرفق بالبرنامج.


1. مقــــدمــــة

1. مقــــدمــــة

الإصدار الأول من "أسرار المجاهدين" تم نشره قبل سنة من الآن. و كان هذا الإنجاز نقلة نوعية في تقنيات الاتصال الآمن بين المجاهدين عامة و الاستخبارات الجهادية خاصة. و من وحي التجربة العملية ظهرت الضرورة لتطوير النسخة الأولى لتقدم ميزات جديدة تسهل تبادل المعلومات و تضيف بعدا أمنيا جديداً للعمل الجهادي الإعلامي و الإستخباراتي على الانترنت.

الإصدار الثاني يأتي بمناسبة مرور سنة على إعلان قيام دولة الإسلام ، دولة العراق الإسلامية. الإصدار الجديد يشكل نقلة نوعية جديدة حيث يتم الاستغناء تماما عن مواقع تحميل الملفات و التي من مساوئها ملاحقة عناوين الإنترنت رغم أن المجاهدين يتخذون جميع التدابير الأمنية باستخدام برامج التخفي و لكن هذا يبطئ من سرعة تبادل المعلومات. في هذا الإصدار يسمح بالتبادل الفوري للرسائل و الملفات المشفرة بجميع أنواعها عبر المنتديات و عبر البريد الخاص أو البريد الالكتروني كما يوفر خاصية التأكد من أصالة الرسائل و البيانات و جميع أنواع الملفات سواء كانت مشفرة أم مفتوحة عن طريق الإمضاء الرقمي و الذي يمثل الهوية الرقمية للأشخاص كما يوفر هذا الإصدار خدمة تبادل الملفات بجميع أنواعها عبر النصوص المفتوحة و المشفرة.

برنامج "أسرار المجاهدين" وجد ليوفر الاتصالات الآمنة لأنه يعتمد على كود مصدري قمنا بتطويره عبر سنوات طويلة مستفيدين مما تم نشره من أبحاث لخوارزميات خضعت لآلاف التحاليل من أكبر العلماء و خبراء التشفير في العالم. و علم التشفير يعامل على أنه سلاح الكتروني و هو كذلك لأنه أساس في تأمين الاتصالات و ضمان سلامة المتصلين و حماية أسرار المجاهدين. و ليس هناك أخطر من أن يعتمد شخص على برنامج أجنبي لحماية أسراره و تامين اتصالاته فربما اكتشف بعد فوات الأوان أن جميع اتصالاته كانت مخترقة من قبل العدو. قال عمر بن الخطاب رضي الله عنه (لست بالخب و لا الخب يخدعني) فأول الاحتياطات الأمنية أن تؤمٍن اتصالاتك ببرامج موثوقة.
و برنامج "أسرار المجاهدين" يشبه في أهدافه برنامج PGP و لكن بميزات جديدة و سرية مفاتيح عالية.


2. تعـــــــريف

2. تعـــــــريف

"أسرار المجاهدين"يقدم أعلى مستويات التشفير على الإطلاق في التشفير اللامتناظر الخاص بتبادل الرسائل و الملفات بجميع أنواعها عبر الشبكات و هو أول برنامج يوفر هذا النوع من التشفير من صناعة إسلامية بتشفير متناظر بطول 256 بت و بمفاتيح لا متناظرة بطول 2048 بت عالية السرية.

"أسرار المجاهدين" يدمج أعلى مستويات ضغط البيانات قبل تشفيرها لتصغير حجمها و يقوم باستخدام تقنية جديدة سميت بالتشفير الشبح و هذه الخاصية تمكن البرنامج من تغيير خوارزمية التشفير عشوائيا في كل مرة يتم فيها تشفير ملف و إنتاج مفتاح جلسة عشوائي يتغير في كل مرة مما يسمح بالإفلات من محاولات تحليل الملفات المشفرة بحيث أن كل ملف يتم تشفيره بخوارزمية مختلفة من مجموع خمس خوارزميات يستخدما البرنامج.

"أسرار المجاهدين" يستخدم الخمس خوارزميات التي تم اختيارها من قبل خبراء التشفير في تصفيات اختيار خوارزمية "AES "، جميعها بمفاتيح بطول 256 بت. و للعلم فان مفتاح بطول 256 بت في خوارزمية AES يكافئ مفتاح بطول 15360 بت من نوع مفاتيحPGP.

تقنية التشفير اللامتناظر تسمح بنقل المفاتيح العامة عبر الشبكة و يمكن نشر المفاتيح العامة في المنتديات الجهادية و تستخدم بصمة المفتاح للتعرف على هوية جهة الاتصال و يستخدم المفتاح العام في تشفير الملفات قبل إرسالها. و المفاتيح المستخدمة نفسها مشفرة لا يمكن استخدامها أو تحليلها ببرامج أخرى.


3. مــــزايا البرنامج

3. مــــزايا البرنامج

التشفير باستخدام أفضل خمس خوارزميات في علم التشفير. (AES finalist algorithms)ج
مفاتيح تشفير متناظر بطول 256 بت (Ultra Strong Symmetric Encryption)ج
مفاتيح تشفير لامتناظر RSA بطول 2048 بت (زوج مفتاح عام و خاص).
ضغط بيانات مدمج (أعلى مستويات الضغط)
مفاتيح و خوارزميات متغيرة بتقنية التشفير الشبح. (Stealthy Cipher)ج
التعرف التلقائي على خوارزمية التشفير أثناء فك التشفير. (Cipher Auto-detection)ج
تقنية المسح الآمن للملفات بحيث يتم مسح الملفات مع استحالة استرجاعها. (Files Shredder).
التراسل المشفر عبر الرسائل النصية الفورية يدعم استخدام المنتديات(Secure Messaging). جديد
تحويل الملفات بجميع أنواعها إلى نصوص يتم تبادلها عبر المنتديات(Files to Text Encoding). جديد
إنتاج البصمة الرقمية للملفات و التأكد من صحتها.
الإمضاء الرقمي للرسائل و الملفات و التأكد من أصالة الرسائل و الملفات.
البرنامج مكون من ملف واحد مرفق بملف المساعدة لا يحتاج إلى تثبيت و يمكن تشغيله من ذاكرة محمولة.


4. إدارة المفاتـــيح

4. إدارة المفاتـــيح

عند تشغيل البرنامج لأول مرة قم بضغط زر "إدارة المفاتيح Keys manager" سوف تحصل على النافذة التالية حيث تكون قاعدة بيانات المفاتيح فارغة.

قاعدة بيانات فارغة

للمزيد
 4.1 إنتاج و إضافة مفاتيح جديدة .
4.2 تغيير كلمة السر لمفتاحك الخاص .
4.3 البصمة الرقمية للمفتاح العام.


4.1 إنتاج و إضافة مفاتيح جديدة

4.1 إنتاج و إضافة مفاتيح جديدة

اضغط على زر "إنتاج مفاتيح Generate keys" سوف تحصل على النافذة التالية. قم بملء فراغات اسم المستخدم "Username". و جملة السر "Passphrase" و تأكيد جملة السر "Confirm Passphrase" ثم اضغط على زر "إنتاج الآن Generate Now ". إذا كان جهازك يدعم اللغة العربية، يمكنك استخدام اللغة العربية في تعريف اسم المستخدم و جملة السر. اضغط على أزرار اتجاه الكتابة لاختيار لغة الكتابة (عربي- لاتيني). قد يستغرق إنتاج مفتاح 2048 بت فترة تتراوح بين دقيقتين و خمسة دقائق على جهاز يعمل بسرعة 2.4 جيغاهرتز.

إدخال الاسم وجملة المرور

يكون البرنامج حين إنتاج المفاتيح مجمدا و يقوم باستغلال المعالج الدقيق"microprocessor " بنسبة 100%. بعد الانتهاء من إنتاج "زوج مفتاح Key pair " يمكنك إغلاق النافذة. تبين لك المعلومات في "الحالة Status " الفترة الزمنية التي استغرقها إنتاج المفاتيح. بعد انتهاء العملية يكون هناك ملفين جديدين و هما بشكل ((publicXXXXXXXX.akf و privateYYYYYYYY.akf)) حيث يمثل الرقم XXXXXXXX رقم تعريف المفتاح العام و يمثل الرقم YYYYYYYY رقم تعريف المفتاح الخاص أو ما يعرف بـ (Key ID ) و يتم حفظهما في نفس مجلد البرنامج. يجب نسخ المفتاحين و نقلهما لمكان آمن (قرص مدمج أو ذاكرة محمولة...الخ) كنوع من النسخ الاحتياطي لأنه يستحيل استرجاع المعلومات المشفرة بالمفتاح العام من دون المفتاح الخاص. بعد إنتاج المفاتيح يمكنك تفعيلها عبر إدراجها بقاعدة بيانات المفاتيح الفعالة. قم بالضغط على زر "إدراج مفتاح Import key " سوف تحصل على النافذة التالية.

إدراج المفتاحين العام والخاص

قم بإدراج المفتاحين (العام و الخاص) مرة تلو الأخرى. عند إدراج المفتاح الخاص سوف يطلب منك البرنامج جملة السر "Passphrase " لأن كل مفتاح خاص مشفر بجملة سرية خاصة به. بعد إدراج عدة مفاتيح يكون شكل نافذة "إدارة المفاتيح" كالتالي. تظهر المفاتيح العامة باللون الأزرق مع الشكل مفتاح أزرق بينما تظهر المفاتيح الخاصة باللون الزهري مبينة بـشكل مفتاحين (أزرق و أحمر) . يرمز المفتاح الأزرق للمفتاح العام بينما يرمز اللون الأحمر للمفتاح الخاص. يظهر المفتاح المختار حاليا "Selected" باللون الأصفر.

المفاتيح التي يتم إدراجها تصبح فعالة في قاعدة البيانات الموجودة بالملف "AsrarKeys.db". يمكن الاستغناء عن المفاتيح بعد دمجها في قاعدة البيانات و لكن يجب الحفاظ عليها في مكان آمن كنسخ احتياطية.

إدارة المفاتيح

لإلغاء مفتاح من قاعدة البيانات (قائمة المفاتيح الفعالة) قم باختيار المفتاح المعين ثم اضغط على زر "إلغاء مفتاح Remove key ".يتم إلغاء المفتاح من قاعدة البيانات و تبقى النسخة الأصلية التي تم إدراج المفتاح منها.

عند اختيار مفتاح عام يمكن استخراج نسخة منه عن طريق الضغط على "استخراج مفتاح عام Export Public Key ".
المفاتيح من 2048 بت آمنة لفترة تزيد على العشر سنوات إلا أن المفاتيح الحالية للبرنامج لا يمكن الحديث عن فترة صلاحية قصوى لها لأن المفاتيح مضغوطة و مشفرة لمنع حتى مجرد استخدامها في برامج أخرى. فيما يلي مثال عن ملف مفتاح عام بطول 2048 بت مشفر:

#---Begin Al-Ekhlaas Network ASRAR El Moujahedeen V2.0 Public Key 2048 bit---#
pyHAv5RbPuhWmwfeX+KjrJk9iHBjnCI1sKN8CqTbYZR3K6nqjk0hc1GXWnJ
U7QpiWLsgR6J+rsgSe8J5zJSh5oPCrzv2+K540q0MMwi8udJ5LpiWm20IoTy
ti0VrNxSXi0Mpohzc+pWOwMNDdaSKW1IOyXc+kd3ybFRJHXNXNUKPwDCn
/XPtSFNrWYj3vJVuBWn4VA7NTrOdzw2uTMJcNo3IGQA/hYDAOWY6bm+GZ
qL+61gXzLv52gg9X8Fxle9vleG+sSt8sjThHGWO2W0WNGP5imvMG0ZtGaM
eVvmEKdTKQxCW3Wmib0I4qLjYxXCEg/JgQosrMPuXd4Jf4VTQLQB37Yk5Ny
91oBgAm+mbNJjkl9Iko+mIAjD0MmjO+3niP/t19/Ezqb/+8EZvbriqmpBy2Jd
mm6CNTGX1PDLgGhPibTDnzL2WqghB7l34YX1ESXp/QXV7eKabdp6BkCqhw
8ZdDPcoLQzUbHswlRt8xcuSViHujCZ9Ds8OHhQqVizzXzCU1r1ApzWsiEu74cU
RAKCmqSbM2h1jGuSbastL/dUn/goxPGqTKjfvMg==
#---End Al-Ekhlaas Network ASRAR El Moujahedeen V2.0 Public Key 2048 bit----#

إذا حصلت على مفتاح عام بأحد المنتديات على شكل نص يمكنك نسخ المحتوى و حفظه في ملف بامتداد ".akf" ثم استخدام إدارة المفاتيح في البرنامج (Keys Manager ) لإدراجه في قاعدة بيانات المفاتيح عن طريق "Import Key".
عند اختيار مفتاح خاص يمكن استخراج نسخة جديدة منه أو استخراج المفتاح العام المرتبط به لأن المفتاح الخاص يحتوي على المفتاحين معا (زوج مفتاح Key Pair ). قم بإدراج كلا المفتاحين (العام و الخاص) حيث يتم استخدام الجزء العام منه بإرساله لمراسليك و الذي يستخدمونه لتشفير الرسائل المرسلة إليك. و يتم استخدام الجزء الخاص لفك التشفير.
في قائمة المفاتيح تظهر المفاتيح العامة للجهات التي تقوم بمراسلتها.


4.2 تغيير كلمة السر لمفتاحك الخاص

4.2 تغيير كلمة السر لمفتاحك الخاص

يمكن تغيير الجملة السرية التي تحمي مفتاحك الخاص و تحمي أيضا ملف "زوج المفتاح Key pair" عن طريق "تغـيـير جملة السر ...Change Passphrase ". عندما تضغط على زر تغيير الجملة السرية للمفتاح الخاص تظهر لك النافذة التالية حيث يتم إدخال جملة السر الحالية و جملة السر الجديدة مع تأكيد الجملة السرية الجديدة بعدها اضغط على "تطبيق التغيير Apply Change". ثم أغلق النافذة لتعود إلى نافذة "إدارة المفاتيح".

تعديل كلمة المرور

بعد تغيير الجملة السرية لا تنسى أن تقوم باستخراج نسخة جديدة منه و حفظها باستخدام"Private key Export " و يتم استبدال الملف السابق بالملف الجديد بعد أن يطلب منك البرنامج تأكيد الاستبدال. يقوم البرنامج بتحذيرك من احتمال إرسال مفتاح خاص عبر الشبكة. المفتاح الخاص في حد ذاته مشفر بجملة سرية "Passphrase" و لكن لا معنى لإرساله عبر الشبكة. فهو خاص بفك التشفير فقط.

تأكيد استبدال الملف

للحصول على معلومات مفتاح ما قم بالنقر المزدوج عليه "Double click".
في حالة طلبت معلومات عن مفتاح عام فإن النافذة التالية تظهر لك حيث تبين الصورة أن المعلومات تتعلق بمفتاح عام و تظهر صورة مفتاح واحد.

معلومات عن مفتاح عام

تستطيع الآن نسخ معلومات المفتاح بالنقر على زر "نسخ Copy " و لصق المعلومات في المكان الذي تريد و يجب نشر هذه المعلومات مع مفتاحك فالبصمة الرقمية للمفتاح هي التي تؤكد انك صاحب مفتاح ما. و لكن يجب إيصال هذه المعلومات للجهة التي ترغب في التراسل معها بعدة طرق حتى تتأكد هذه الجهة أنك صاحب مفتاح عام معين.


4.3 البصمة الرقمية للمفتاح العام

4.3 البصمة الرقمية للمفتاح العام

البصمة الرقمية هي الوسيلة للتأكد من هوية المفتاح الذي بحوزتك فكل مفتاح له بصمة خاصة به لا يمكن تقليدها أو تزويرها. لمقارنة البصمة الرقمية التي حصلت عليها (FPb) مع بصمة المفتاح الحالي (FPa) في إدارة المفاتيح قم باستخدام نافذة مقارنة البصمات بالنقر على الزر. قم بنسخ و لصق البصمة في مكان الإدخال FPb .

مقارنة البصمة الرقمية

تستطيع أيضا تخزين معلومات المفتاح في صيغة ملف نصي بالنقر على زر "حفظ باسم ...Save as ".

تخزين معلومات المفتاح

في حالة طلبت معلومات عن مفتاح خاص فإن النافذة التالية تظهر لك حيث تبين الصورة أن المعلومات تتعلق بمفتاح خاص و تظهر صورة زوج مفتاح (خاص و عام). المفتاح الخاص يحتوي أيضا على نسخة من المفتاح العام. أنظر الصورة التالية:

المفتاح الخاص يحتوي أيضا على المفتاح العام


5. المسح الآمن للملفات

5. المسح الآمن للملفات

لأن الملفات التي تتعامل معها لها طبيعة خاصة و تتطلب سرية تامة في التعامل معها فان البرنامج يوفر خاصية المسح الآمن للملفات التي تتعامل معها و الموجودة على القرص الصلب لجهاز الحاسوب أو على ذاكرة محمولة. خاصية مسح الملفات التي يستخدمها نظام تشغيل الحاسوب ليست آمنة و ذلك لإمكانية استرجاع الملفات التي قمت بمسحها باستخدام "Delete " وذلك باستعمال برامج خاصة المعروفة باسم (Files Recovery ) و هذا يرجع لطبيعة عملية المسح الخاصة بنظام التشغيل الذي لا يقوم فعليا بمسح الملفات و إنما إلغاء تعريفها بالنظام ليسهل الكتابة في مكان تواجدها على القرص مستقبلا مما يسمح باسترجاعها في حالات كثيرة. عندما تتعامل مع ملفات سرية يمكنك الاستفادة من خاصية المسح الآمن التي يوفرها برنامج أسرار المجاهدين حيث يقوم بعملية تدمير "Shredder " فعلي للملف و يتم ذلك على مراحل تتراوح بين 4 و 10 مرات بطريقة تلقائية.

النافذة التالية تبين هذه الخدمة "تدمير الملفات". بعد أن تختار المجلد الذي تتواجد به الملفات تظهر هذه الأخيرة في قائمة الملفات الحالية "Current Folder Files " قم باختيار الملفات التي ترغب في تدميرها عن طريق الضغط على مفتاح "Ctrl" ثم أنقر على كل ملف، بعد ذلك قم بسحبها بالفأرة "Drag and Drop " و وضعها بداخل سلة الملفات المستهدفة بعملية التدمير. يمكن أيضا أن تنقر مزدوجا على كل ملف لنقله للسلة أو النقر المزدوج عليه داخل السلة للتراجع عن عملية إتلافه. لإتلاف جميع الملفات في مجلد معين أنقر على زر "Select All ". بعد الانتهاء من اختيار الملفات قم بالنقر على زر "تدمير الملفات Shred Files " يقوم البرنامج بطلب تأكيد أخير على عملية الإتلاف بعدها يتم إتلاف الملفات نهائيا. لرؤية قائمة محدثة للملفات أنقر على زر "Refresh".للتراجع عن مسح ملفات قم بمسح قائمة الملفات داخل السلة وذلك بالنقر على "مسح Clear ". تستطيع رؤية ملفات من نوع ما في قائمة الملفات الحالية باستخدام مرشح الملفات "Filter Extension " الذي يظهر الملفات التي تنتهي بامتداد معين. لإظهار جميع الملفات يتم استخدام الامتداد ( *.*) في مرشح الملفات. أثناء انجاز عملية تدمير الملفات يبين الشريط السفلي عملية التدمير (المسح الآمن) و عدد مرات المسح المستخدمة. يمكن تحديد عدد مرات المسح الآمن في خيارات البرنامج "Preferences" كلما كان عدد المرات أكبر كلما كانت العملية أبطأ و خاصة بالنسبة للملفات الكبيرة بينما لن تلاحظ الفرق بالنسبة للملفات الصغيرة (أقل من ميغابايت).

إتلاف الملفات

للمزيد
 6.2 خيارات إتلاف الملفات File Shredder


6. خيارات البرنامج

6. خيارات البرنامج

البرنامج يعطيك إمكانية التحكم في نسب ضغط الملفات المشفرة و يحدد عدد المرات المستخدمة في إتلاف الملفات الأصلية بحيث يستحيل استرجاعها باستخدام البرامج الخاصة بذلك.
للمزيد
 6.1 ضغط البيانات
6.2 إتلاف الملفات


6.1 ضغط البيانات

6.1 ضغط البيانات

يمكنك أن تختار نسب الضغط المستخدمة قبل التشفير. نسب الضغط العالية تتطلب بعض الوقت في معالجة البيانات (بضع ثواني إضافية للضغط) بالنسبة للملفات الكبيرة (أكبر من 10 ميغا بايت) بينما تكون سرعة الضغط فائقة بالنسبة للملفات الصغيرة (أقل من 3 ميغابايت). و ضغط البيانات مهم جدا خاصة بالنسبة للملفات النصية (تقارير، رسائل، بيانات...الخ) و قد تصل نسب الضغط إلى أضعاف كثيرة. و تزيد سرعة الضغط عن 10 ميغابايت في الثانية. و يوفر البرنامج أربع خيارات: ضغط سريع، ضغط متوسط (عادي) ، ضغط عالي (بطيء) كما تتوفر إمكانية تعطيل الضغط.

بينما يستحسن استخدام الضغط العالي في معظم الحالات فإن إلغاء الضغط يكون مفضلا في حالة ملفات الفيديو الضخمة (أكبر من 50 ميغابايت) حيث أن الضغط لا يعطي سوى نسب قليلة و ذلك لأن طبيعة الملفات هي مضغوطة أصلا. و نسبة الضغط تتراوح بين 0% بالنسبة للملفات المضغوطة و قد تقترب من 100% بالنسبة للملفات النصية. فإذا كانت نسبة الضغط 90% فهذا يعني أن الملف المضغوط و المشفر يمثل فقط 10% من حجم الملف الأصلي. و تكون بذلك نسبة الضغط هي نسبة التوفير في حجم الملف الناتج عن عملية الضغط.


6.2 إتلاف الملفات

6.2 إتلاف الملفات

يتم هنا اختيار عدد مرات إتلاف (تدمير) الملف بحيث يستحيل استرجاعه. و الخيارات المتاحة هي : 4، 6، 8 أو 10. عند تغيير الخصائص و حفظها بالنقر على زر موافق "OK " يتم إنشاء ملف خاص بالإعدادات الجديدة اسمه "asrar.ini". بالنقر على زر "إلغاء Cancel " يتم إهمال التغييرات الحالية. النافذة التالية توضح هذه الخصائص.

خيارات إتلاف الملفات


7. التشفير اللامتناظر للتراسل الآمن عبر الشبكات

7. التشفير اللامتناظر للتراسل الآمن عبر الشبكات

التشفير اللامتناظر هو تشفير خاص بتبادل الرسائل و الملفات عبر الشبكات. حيث يتم التشفير باستخدام مفتاح يسمى المفتاح العام بينما يتم فك تشفير الرسائل أو الملفات المشفرة عن طريق المفتاح الخاص.
عندما تقوم بإنتاج زوج مفاتيح فإنك تحصل على مفتاح عام و مفتاح خاص. فإذا كنت ترغب في أن يرسل إليك شخص ما ملف سري فما عليك إلا أن ترسل له مفتاحك العام فيقوم هو باستخدام هذا المفتاح في تشفير الملف و إرساله إليك. عندما يصلك الملف المشفر تقوم أنت بفك تشفيره بالمفتاح الخاص.

للمزيد
 7.1 تشفير الملفات بالمفتاح العام
7.2 فك التشفير للملفات بالمفتاح الخاص


7.1 تشفير الملفات بالمفتاح العام

7.1 تشفير الملفات بالمفتاح العام

قم باختيار الملف الذي ترغب بتشفيره "Select File to encrypt ". ثم قم بالنقر المزدوج على المفتاح العام للجهة التي ترغب بمراسلتها و يظهر المفتاح المختار في "اسم المستقبل Recipient User ID " بعدها انقر على زر "تشفير Encrypt ". عند النقر المزدوج على مفتاح يتحول لونه من الأصفر إلى الأحمر مما يبين انه المفتاح الذي سوف يستخدم في التشفير .

اختيار المفتاح الخاص (تم مسح أسماء المستخدمين لضرورة أمنية)

إذا قمت باختيار "التشفير الشبح Stealthy Cipher " فان خوارزمية التشفير يتم اختيارها تلقائيا بطريقة عشوائية بينما يمكن تحديد خوارزمية التشفير من مجموع خمس خوارزميات إذا قمت بتعطيل خاصية "التشفير الشبح Stealthy Cipher ".

إذا رغبت في إتلاف (المسح الآمن) الملف الأصلي بعد انتهاء عملية التشفير قم باختيار "Shred Out Original File ". إذا قمت باختيار هذه الخدمة عن طريق الخطأ فإن هناك فرصة أخيرة للتراجع حيث يطلب منك البرنامج تأكيد عملية إتلاف الملف الأصلي. بعد النقر على زر "تشفير Encrypt " تظهر نافذة تطلب منك الانتظار. و العملية تمر عبر ثلاث مراحل: الضغط، التشفير و أخير حفظ الملف المشفر. الملف المشفر يعطى نفس الاسم للملف الأصلي مع إضافة الامتداد "enc." و يتم حفظه في نفس مجلد الملف الأصلي. سرعة التشفير تزيد عموما عن 15 ميغابايت في الثانية. بعد تشفير ملف بالمفتاح العام فإنه يستحيل فك تشفيره من دون المفتاح الخاص للشخص المرسل إليه .

عملية الضغط ثم التشفير

في نهاية العملية تظهر رسالة تخبرك بإنجاز عملية التشفير بنجاح. إذا قمت بطلب إتلاف الملف الأصلي تلقائيا بعد تشفيره فإن الرسالة تؤكد لك تشفير الملف بنجاح و إتلاف النسخة الأصلية.


7.2 فك التشفير للملفات بالمفتاح الخاص

7.2 فك التشفير للملفات بالمفتاح الخاص

عندما يصلك ملف مشفر بمفتاحك العام المنشور بالمنتديات مثلا فإن بإمكانك فك تشفير الملف باستخدام المفتاح الخاص بك.

قم باختيار الملف المشفر و الذي ينتهي بالامتداد "enc."
قم باختيار المفتاح الخاص (Pub/ Priv) بالنقر المزدوج عليه حيث يتحول لون المفتاح من الأصفر (لون المفتاح الحالي) إلى اللون الأحمر ثم أنقر على زر "فك التشفير Decrypt ".

يقوم البرنامج بطلب الجملة السرية الخاصة بالمفتاح الخاص لأن من دون الجملة السرية يستحيل فك التشفير و ذلك لكون المفتاح الخاص مشفر باستخدام الجملة السرية "Passphrase". حيث أن قوة التشفير تعتمد على خوارزمية من 256 بت فإنه يجب استخدام جملة سرية بطول مكافئ لقوة التشفير و طول الجملة السرية يستحسن أن يتراوح بين 20 و 36 حرفا. أقل طول يسمح به البرنامج هو ثمانية حروف. يفضل استخدام الحروف و الأرقام و الرموز في كلمة السر .

إدخال كلمة مرور المفتاح الخاص

إذا قل طول جملة السر عن الحد الأدنى تعرض مفتاحك الخاص للخطر إذا تمت سرقته من جهازك.
و الخطر الحقيقي على مفاتيحك هو نفسه الخطر الذي يهدد جهازك و هو برامج التجسس التي تمكن أصحابها من اختراق جهازك المتصل بالإنترنت و سرقة ملفاتك.

عند النقر على فك التشفير و كان هناك ملف بنفس الاسم على جهازك (في نفس المجلد) فإن البرنامج ينبهك لذلك و يطلب منك تأكيد استبدال الملف الذي يحمل نفس الاسم أو إلغاء العملية. في حالة لم ترغب باستبدال الملف قم بإلغاء العملية، بعد ذلك قم بتغيير اسم الملف المعني و أعد عملية فك التشفير مرة أخرى. و هذا موضح في الصورة التالية:

تأكيد استبدال الملف

يمكنك ضغط "إلغاء-Cancel " لإلغاء العملية. عند الاستمرار في فك التشفير فإن الرسالة التالية تطلب منك الانتظار. و عملية فك التشفير أطول زمنيا من عملية التشفير. و تستغرق بضع ثواني إضافية.

عملية فك التشفير تعقبها عملية فك الضغط

تحصل في الأخير على رسالة تبين نجاح عملية فك التشفير.

رسالة تأكد نجاح عملية فك التشفير

إذا قمت باستخدام مفتاح خاص غير مناسب فإن الرسالة التالية تبين لك ذلك.

رسالة توضح أن المفتاح الخاص المستخدم غير مناسب


8. التراسل عبر النصوص المشفرة الفورية

8. التراسل عبر النصوص المشفرة الفورية

خاصية جديدة تمت إضافتها لتسهيل التراسل المشفر عبر المنتديات أو عبر البريد الالكتروني دون الحاجة لإرسال ملفات أو تحميلها عبر مواقع التحميل.

للمزيد
 8.1 إرسال الرسائل المشفرة الفورية
8.2 استقبال الرسائل المشفرة و فكها


8.1 إرسال الرسائل المشفرة الفورية

8.1 إرسال الرسائل المشفرة الفورية

الصورة التالية تمثل الواجهة الجديدة للإصدار الثاني لبرنامج أسرار المجاهدين حيث تم إضافة خصائص جديدة. منها خاصية التشفير الفوري للرسائل و نقلها عبر البريد الالكتروني أو عبر المنتديات في شكل رسائل نصية مشفرة و التي نحن بصدد مناقشتها الآن.

إدخال كلمة مرور المفتاح الخاص (تم مسح أسماء المستخدمين لضرورة أمنية)

عندما نرغب في التراسل المشفر عبر الرسائل النصية الفورية من خلال المنتديات الجهادية نقوم بما يلي:
نختار المفتاح العام للشخص الذي نرغب في مراسلته (Remote User ) و ذلك عن طريق النقر المزدوج على المفتاح في قائمة المفاتيح أو اختيار المفتاح ثم الضغط على زر المفتاح الأزرق (المفتاح العام). بعدها نختار المفتاح الخاص بنا (Local User ) عن طريق النقر المزدوج على المفتاح أو اختيار المفتاح ثم الضغط على زر المفتاح الأحمر (المفتاح الخاص). إذا نسيت اختيار المفتاح الخاص و ضغطت على زر التراسل فان الرسالة التالية تنبهك لذلك. رسالة مماثلة تنبهك في حالة لم تختر المفتاح العام لمراسلك.

يتوجب عليك اختيار مفتاح خاص

بعد الانتهاء من اختيار المفتاح الخاص و المفتاح العام لمراسلنا نضغط على زر التراسل (Messaging ) عندها تظهر الواجهة التالية.

واجهة التشفير الفوري

هنا تظهر واجهة التراسل الفوري عبر المنتديات. في أعلى الواجهة يظهر اسم المستخدم الذي نقوم بمراسلته (Remote User ) و يظهر تحته مباشرة مفتاحنا الخاص (Local User ). الذي تستخدمه في فك تشفير الرسائل التي نستقبلها من مراسلنا (Remote User ).

نقوم بكتابة رسالتنا مباشرة أو أنقلها هنا عن طريق النسخ و اللصق (Copy and Paste ) أو بتحميلها مباشرة إذا كانت جاهزة عن طريق تحميل الملف (...Load).

اضغط على هذه الأيقونة للكتابة باللغة العربية. يقوم البرنامج تلقائيا بتحويل لوحة المفاتيح و أيضا تحويل اتجاه الكتابة المناسب لها.

اضغط على هذه الأيقونة للكتابة باللاتينية. يقوم البرنامج تلقائيا بتحويل لوحة المفاتيح و أيضا تحويل اتجاه الكتابة المناسب لها. عند الانتهاء من تجهيز الرسالة نقوم بالضغط على زر التشفير (Encrypt ).

عندما تتم العملية بنجاح فان البرنامج يقوم بإظهار الرسالة المشفرة في نافذة جديدة "رسالة مشفرة للإرسال " (Message to Send Encrypted ). البرنامج بعد تشفير الرسالة يقوم تلقائيا بنسخها في الذاكرة (Clipboard).

للمزيد من المرونة في التعامل مع المنتديات و للحفاظ على الشكل المنسق للرسالة المشفرة فان البرنامج يتيح لك ثلاثة خيارات إضافية في النسخ.

اضغط على هذا الزر لإدراج الرسالة داخل علامة (Tag ) [CODE] [/CODE].
اضغط على هذا الزر لإدراج الرسالة داخل علامة [PHP] [/PHP] .
 اضغط على هذا الزر لإدراج الرسالة داخل علامة [LEFT] [/LEFT].

يقوم البرنامج تلقائيا بنسخ الرسالة إلى الذاكرة مع العلامة المختارة و يبقى عليك فقط الذهاب إلى بريدك أو داخل المنتدى أو عبر الرسائل الخاصة و تقوم بلصق المحتوى عن طريق Ctrl+V أو باستخدام الزر الأيسر للفأرة (Mouse) و الضغط على لصق Paste .

تنسيق وتشفير رسالة

إذا كنت ضغطت على زر [image] فإن رسالتك تظهر بالشكل التالي عند لصقها و قبل إرسالها. مثال عن ذلك الرسالة التالية. حيث نقوم بإرسال رسالة خاصة عبر أحد المنتديات و نقوم بلصق محتوى الرسالة المشفرة.

إرسال رسالة مشفرة عبر منتدى

و بعد إرسالها فإن المنتدى يقوم بتحويل علامة PHP لتبدو منسقة كما في الشكل التالي:
الرسالة كما تظهر منسقة بكود PHP في المنتديات

و عند استخدام العلامة CODE بعد الضغط على زر [image] فإن الرسالة تبدو بعد إرسالها منسقة كما في الصورة التالية:

الرسالة كما تظهر منسقة بكود CODE في المنتديات


8.2 إستقبال الرسائل المشفرة و فكها

8.2 إستقبال الرسائل المشفرة و فكها

عندما تستقبل رسالة مشفرة بداخل بريدك قم بنسخها و لصقها داخل النافذة المخصصة لاستقبال الرسائل المشفرة (Received Encrypted Message ).
قم بإدخال كلمة السر (Private key Passphrase) التي استخدمتها لحماية مفتاحك الخاص . ثم اضغط على زر فك التشفير (Decrypt) . يقوم بعدها البرنامج بالعمل على فك التشفير و الذي يستغرق بضعة ثواني .

استقبال رسالة فورية مشفرة

تظهر لك نافذة تبين عملية تقدم فك التشفير. العملية تستغرق بضعة ثواني.

عند النقر على فك التشفير و كان هناك ملف بنفس الاسم على جهازك (في نفس المجلد) فان البرنامج ينبهك لذلك و يطلب منك تأكيد استبدال الملف الذي يحمل نفس الاسم أو إلغاء العملية. في حالة لم ترغب باستبدال الملف قم بإلغاء العملية، بعد ذلك قم بتغيير اسم الملف المعني و أعد عملية فك التشفير مرة أخرى. و هذا موضح في الصورة التالية:

تأكيد استبدال الملف

عند نجاح عملية فك التشفير تظهر الرسالة في نافذة جديدة "Received Message Decrypted ".
كما تظهر رسالة قصيرة تخبرك بذلك في أسفل النافذة "Message Decrypted Successfully ".
كما يظهر أيضا اسم الخوارزمية التي استخدمت في التشفير, في المثال التالي الخوارزمية المستخدمة هي: (Rijndael-AES)

الرسالة بعد فك التشفير ومعلومات في الشريط السفلي

يمكنك الاحتفاظ بنسخة من الرسالة عن طريق تخزينها باستخدام الزر "خزن باسم...Save as " .

البرنامج يحتفظ بنسخة من الرسائل المتبادلة و يميزها بالألوان حيث أن الرسائل الصادرة تظهر باللون الأزرق بينما تظهر الرسائل الواردة باللون الأحمر. لرؤية الرسائل اضغط على النافذة "Messages Logging ". يمكن أيضا تخزين الرسائل المتبادلة داخل ملف.


9. تحويل الملفات إلى نصوص

9. تحويل الملفات إلى نصوص

تقوم هذه الخاصية بتحويل أي نوع من الملفات من ملفات ثنائية (binary) مثل البرامج و الصور و ملفات الصوت و الفيديو و الملفات المضغوطة التي نقوم عادة بتشفيرها قبل إرسالها. و لتفادي استخدام مواقع التحميل المجاني خاصة بالنسبة للملفات الصغيرة الحجم فإننا نقوم بعد تشفيرها بعملية تحويلها إلى نصوص يمكن إدراجها داخل الرسائل النصية مباشرة أو تبادلها عبر المنتديات.
نؤكد هنا أن هذه العملية تسهل تبادل الملفات الصغيرة الحجم و لا نلجأ لاستخدامها مع الملفات الكبيرة. الملفات المحولة إلى نصوص تزيد بنسبة 30% عن حجمها الأصلي.

للمزيد
 9.1 تحويل ملف قبل إرساله
9.2 استقبال ملفات نصية و تحويلها إلى صيغتها الأصلية


9.1 تحويل ملف قبل إرساله

9.1 تحويل ملف قبل إرساله

لتحويل ملف قبل إرساله عبر الرسائل الخاصة مثلا فإننا نقوم بالتالي. نضغط على زر ترميز ملف
(Encode File ) و نختار الملف الذي كنا قد قمنا بتشفيره سابقا.

تحويل ملف

نضغط الزر "ترميز ملف" ثم نختار الملف.

اختيار ملف

إذا كان الملف الذي نرغب في تحويله إلى نص لا يحتوي على معلومات سرية فإننا لا نحتاج إلى تشفيره بل نقوم بتحويله إلى نص مباشرة. عملية الترميز (Encoding ) ليست تشفيرا و إنما تحويل إلى نصوص يمكننا تبادلها عبر المنتديات مثلا. بعد اختيار الملف و نجاح عملية التحويل تظهر الرسالة التالية.

إتمام تحويل الملف

إذا اخترت مثلا ملف اسمه: Islamic_state.rar.enc فإن الملف النصي المنتج من هذه العملية يصبح اسمه: Islamic_state.rar.enc.text دلالة على أن الملف يحتوي على نص.
قم بفتح الملف باستخدام محرر نصوص و نسخ محتواه و لصقه بداخل بريدك الخاص و قم بإرساله.

إذا أردنا إرسال ملف كبير نوعا ما فيجب أن نعلم أن حجم نص كل رسالة في المنتديات محدود بحوالي 100 كيلو بايت. و لذا فان الملفات الكبيرة (بالنسبة للمنتديات) يتم تقسيما إلى عدد من الملفات النصية و التي يتم إرسالها كل واحدة في رسالة جديدة. فمثلا نريد إرسال ملف حجمه 390 كيلو بايت نقوم بالذهاب إلى "خصائص متقدمة في ترميز الملفات File Encoding Advanced Options ".

بعد ذلك نقوم باختيار نوع التنسيق الذي نرغب فيه مثلا Php . ثم نقوم باختيار حجم 100 كيلو بايت في خاصية تقسيم الملفات. 100 كيلو بايت هو الحد الأقصى الذي يسمح به في مشاركة واحدة داخل المنتديات.

خيارات تقسيم الملف ونوع التنسيق

بعد الانتهاء نذهب إلى نافذة ترميز الملفات و نضغط على "ترميز ملف Encode File" ثم نختار الملف و نضغط "فتح Open".
يقوم البرنامج بتحويل الملف المطلوب إلى ملف نصي و تقسيمه إلى عدة أجزاء.
علما أن مجموع الملفات الناتجة عن العملية تزيد في الحجم عن الملف الأصلي بنسبة 30%.

"ترميز ملف Encode File"

حيث يكون حسب المعادلة التالية:
الحجم الناتج= 1.3 * الحجم الأصلي.

فإذا كان مثلا حجم الملف الأصلي 390 كيلوبايت فان الحجم الناتج يصبح 507 و بالتالي فان عدد الملفات الناتجة عن العملية هو 6 ملفات. انظر الصورة التالية.
الملف الأصلي: img.jpg.enc
الملفات النصية بعد تحويلها و تقسيمها:
img.jpg.enc.001
img.jpg.enc.002
img.jpg.enc.003
img.jpg.enc.004
img.jpg.enc.005
img.jpg.enc.006

الملفات الناتجة عن التحويل

و بالتالي سوف نقوم بإرسال هذه الملفات عبر ستة رسائل كل رسالة تحتوي على محتوى ملف واحد. يمكن تقسيم الأجزاء إلى أحجام اصغر لكن يبقى الحجم 100 كيلوبايت هو أقصى حجم تتحمله المنتديات لكل رسالة. إذا وضعنا الحجم 0 فانه يتم إلغاء خاصية تقسيم الملف.

و إذا فتحنا كل ملف فان شكله يظهر بالشكل التالي حيث يظهر في أول سطر و آخر سطر علامة التنسيق و هي في هذا المثال PHP. يمكن أيضا اختيار تنسيق آخر مثل CODE أو LEFT أو عدم استخدام تنسيق عن طريق اختيار التنسيق None.

[PHP]
...
محتوى الملف...
….
….
[/PHP]


9.2 إستقبال ملفات نصية و تحويلها الى صيغتها الأصلية

9.2 إستقبال ملفات نصية و تحويلها الى صيغتها الأصلية

إذا وصلتك رسالة مرمزة عبر بريدك مثلا نقوم باستقبالها بإتباع الخطوات التالية:
- إذا كانت الرسالة من جزء واحد فقط فإننا نقوم بنسخها ثم ننشئ ملف مثلا received.text و نقوم بوضع المحتوى بداخل هذا الملف و نقوم بحفظه .
- نقوم بفتح البرنامج ثم الذهاب إلى Decode File و نختار الملف received.text ثم نضغط على "فتح Open" يقوم البرنامج باسترجاع الملف الأصلي و تخزينه أيضا باسمه الأصلي.
إذا كان هذا الاسم موجودا عندك فإن البرنامج ينبهك لذلك و يطلب منك إما إلغاء التحويل أو استبدال الملف القديم بالملف الجديد. يمكنك إلغاء العملية و الذهاب إلى الملف الموجود عندك و تغيير اسمه ثم الرجوع إلى البرنامج و تحويل الملف.

اختيار الملف لفك ترمزيه

إذا وصلتنا رسالة من عدة أجزاء فإننا نقوم بوضع محتوى كل رسالة في ملف بامتداد يدل على رقم الجزء.
مثلا نضع الجزء الأول في ملف نسميهreceived.001 و الجزء الثاني نخزنه في ملف باسم received.002 و الجزء الثالث نخزنه في ملف باسم received.003 و هكذا مع جميع الأجزاء. بعد ذلك نذهب إلى البرنامج و بعد الضغط على "فك ترميز Decode File " نختار امتداد الملفات (Asrar splitted Files .001 )و نختار أول جزء من الملفات مثلا (received.001 ) يقوم البرنامج تلقائيا بتجميع جميع الأجزاء و إعادة تكوين الملف الأصلي و تخزينه بنفس الاسم الأصلي للملف و نحصل على النافذة التالية لتأكيد نجاح العملية.

إتمام فك ترميز الملف


10. البصمة الرقمية

10. البصمة الرقمية

يوفر البرنامج خدمة التأكد من أصالة (Authenticity) البرامج و الملفات الحساسة التي تحصل عليها من المنتديات أو من أي موقع تحميل عن طريق التأكد من صحة البصمة الرقمية للملف. المواقع المعتمدة لتوزيع البرامج و الملفات الحساسة تقوم أيضا بنشر البصمة الرقمية للملف أو البرنامج المعني. فيتم أخذ البصمة الرقمية ووضعها في المكان المخصص لها ثم حساب البصمة الرقمية للملف و مقارنة النتائج. إذا كانت النتيجة ايجابية و البصمات متطابقة فهذا يعني أن الملف أصلي بينما إذا اختلفت البصمة و كانت نتيجة المطابقة سلبية فهذا يعني أن الملف غير أصلي و لا يمكن الوثوق به.

قد يسأل سائل لماذا هذا كله؟
نقول هنا أن أجهزة الاستخبارات قد تجند شركات في البرمجة لصناعة نسخة ظاهريا تبدو مثل النسخة الأصلية بينما تكون نسخة مغشوشة يسهل اعتراض الرسائل المرسلة بهذه النسخة و قد يعمد العدو أيضا لنشر النسخة المغشوشة. و لكن بفضل الله إذا تم التأكد من البصمة الرقمية فانه يستحيل على العدو اللجوء لأسلوب التصنيع المغشوش.

البصمة الرقمية للبرنامج من عيار 256 بت يتم نشرها مع البرنامج في المنتديات المعتمدة و لا يتم اعتماد أية بصمة من موقع غير المواقع المعلنة.عند كل تحديث للبرنامج نقوم بتحديث البصمة الرقمية و لا يتم اعتماد البصمة إلا إذا كانت منشورة في المواقع المعتمدة. و تكون مسؤولية كل شخص التأكد من البصمة الرقمية قبل البدء في استخدام البرنامج.

للتأكد من أصالة الملف نتبع الخطوات التالية:
1- نضغط على Browse و نختار ملف البرنامج ثم نضغط على فتح Open.

تحويل ملف

2- يقوم البرنامج بحساب البصمة الرقمية ووضعها في الخانة (FFP: File FingerPrint )
3- نقوم بوضع البصمة التي حصلنا عليها من منتدى معتمد للتوزيع و نضعها في الخانة ( (OFP:FingerPrint Original
4- نضغط على الزر "فحصCheck "

اختيار ملف

إذا كانت بصمة الملف مطابقة للبصمة الأصلية فإننا نحصل على النافذة التالية. حيث يظهر إلى اليمين صورة البصمة الرقمية الأصلية و إلى اليسار صورة البصمة الرقمية للملف الذي اخترناه (ملف البرنامج). و تظهر في الوسط صورة سوداء دلالة على تطابق البصمات الرقمية. لقد تعمدنا إلى تمثيل البصمات بشكل مرئي حتى نلفت الانتباه إلى ضرورة التأكد من أن البصمات متطابقة. قمنا بتمثيل كل بصمة في هيئة صورة ثنائية بقياس 16*16 بكسل و بالتالي 256 نقطة تمثل 256 بت للبصمة الرقمية.

مطابقة بصمة الملف

في حالة اختلاف البصمات فان صورة البصمة الوسطى (انظر النافذة التالية) لا تكون سوداء نقية و إنما تحتوي عل نقاط تمثل الاختلاف بين البصمتين. في هذه الحالة يجب عليك مراجعة المواقع الأصلية للتأكد من البرنامج و من البصمة الصحيحة. فقد تكون استخدمت بصمة قديمة مع نسخة محدثة للبرنامج. الرسالة باللون الأحمر تحذرك من الاستمرار في استخدام البرنامج ما لم تتأكد من سبب الاختلاف بين البصمتين.

عدم مطابقة بصمة الملف


11. الإمضاء الرقمي

11. الإمضاء الرقمي

نحتاج في بعض الأحيان أن نتأكد من أن رسالة أو بيان معين هو فعلا من المصدر الذي يدعي ذلك. مثلا إذا وصلتك رسالة من شخص معين فما الذي يؤكد عن أن هذه الرسالة أصلية و أن الشخص الذي كتبها هو فعلا من تعتقد أنه كذلك. ما الذي يؤكد أن بيانا معين نشر على الإنترنت هو فعلا بيان أصيل و ليس مزورا. ما الذي يضمن أن ملفا وصلك مشفرا هو من المصدر الذي تعتقد أنت. إذا كان التشفير يضمن أنك الوحيد الذي يستطيع قراءة الرسائل المرسلة إليك فإن الأصالة الرقمية أو الإمضاء الرقمي هو الذي يضمن لك هوية من أرسل لك هذه الرسالة. الإمضاء الرقمي لا يتعلق فقط بضمان هوية الشخص و إنما بشكل عام هو الذي يضمن أن الرسائل أو البيانات هي من مصدر معين و ليست مزورة.

فمثلا عندما يصدر الإخوة في مركز الفجر للإعلام بيانا فإن باستطاعتهم إمضاء هذا البيان بشكل رقمي حيث يستطيع أي أحد التأكد من أن البيان أصلي و يستحيل على أي أحد تزوير البيان. لإنجاز الإمضاء الرقمي يقوم الإخوة بإنشاء زوج مفتاح و يقومون بنشر المفتاح العام عبر المنتديات الموثوق بها. عند إصدار بيان معين فإن عملية الإمضاء الرقمي تتلخص فيما يلي.

1- يقوم البرنامج بحساب شيفرة "البصمة الرقمية".
2- يقوم البرنامج بإمضاء الناتج باستخدام المفتاح الخاص الذي لا يمتلكه سوى المصدر
3- يقوم الإخوة بإرسال الرسالة مرفقة بالإمضاء الرقمي

للتأكد من أن الرسالة أو البيان هو فعلا بيان أصلي و لم يتم التلاعب به أو تزويره يتم إتباع الخطوات التالية.
1- يقوم البرنامج بحساب شيفرة "البصمة الرقمية".
2- يقوم بإدخال الإمضاء الرقمي المرفق مع الرسالة
3- يقوم باختيار المفتاح العام و الذي هو مفتاح الشخص أو الهيئة التي أرسلت البيان
4- البرنامج ينجز مهمة التأكد من أصالة البيان عن طريق فك الإمضاء الرقمي باستخدام المفتاح العام للمرسل و مقارنة الناتج مع البصمة الرقمية فإذا كانت النتيجة متطابقة فهذا يعني أن الرسالة أصلية و أن الذي أرسلها هو فعلا من يمتلك المفتاح العام الذي استخدمناه. إذا كانت النتيجة غير متطابقة فهذا يعني أن البيان إما مزور أو أنه تم التلاعب فيه و لو بحرف واحد بل أقل من حرف واحد فحذف نقطة أو استبدال فتحة بضمة يلغي أصالة البيان.

الخطوات السابقة معظمها ينجزها البرنامج بشكل تلقائي.

المفاتيح المستخدمة في عملية الإمضاء الرقمي هي نفسها المفاتيح المستخدمة في عملية التشفير لكننا ننصح بتخصيص مفاتيح للإمضاء الرقمي ومفاتيح مختلفة لعملية التشفير و هذا احتياط أمني إضافي.

أما بالنسبة لنوعية المفاتيح فهي تتبع خوارزمية RSA بطول 2048 بت و هي أفضل من خوارزمية DSA و التي كان وراء ظهور هذه الأخيرة وكالة الأمن القومي الأمريكية NSA و التي ضغطت على المعهد الوطني للمقاييس و التكنولوجيا NIST حتى يعتمد هذه الخوارزمية بدلا من خوارزمية RSA. و يعتقد أن خوارزمية DSA التي تعتمد على الخوارزميات المتقطعة قد تكون أضعف من خوارزمية RSA. و يكفي أن وكالة الأمن القومي الأمريكي تدعم خوارزمية الإمضاء الرقمي DSA حتى نقوم نحن باستبعادها بالإضافة إلى أن خوارزمية DSA تعتمد مفاتيح بطول يتراوح بين 512 و 1024 بت مما يجعلها أضعف بملايين المرات من خوارزمية RSA-2048.

آلية العمل

للدخول إلى واجهة الإمضاء الرقمي في الواجهة الرئيسية نضغط على "إمضاء \ فحص" كما في الصورة التالية. و ذلك بعد اختيار مفتاحنا الخاص الذي يستخدم في الإمضاء الرقمي.

إمضاء البصمة الرقمية هو عبارة عن تشفير للبصمة الرقمية باستخدام المفتاح الخاص. و التأكد من صحة البصمة يتم عن طريق فك تشفير البصمة المشفرة باستخدام المفتاح العام و هي العملية العكسية في التشفير بالمفتاح العام. بعد فك التشفير للبصمة يقوم البرنامج بمقارنة بصمة الملف أو الرسالة مع البصمة التي تم فك تشفيرها فإذا تطابقتا فهذا يعني أن البرنامج أو الرسالة أصلية.

خيار الإمضاء والفحص

للمزيد
 11.1 إمضاء الرسائل و البيانات المفتوحة
11.2 فحص أصالة الرسالة المفتوحة
11.3 إمضاء الملفات المشفرة و المفتوحة
11.4 فحص أصالة الملفات المشفرة المفتوحة


11.1 إمضاء الرسائل و البيانات المفتوحة

11.1 إمضاء الرسائل و البيانات المفتوحة

لإمضاء بيان معين و بالتالي نضمن استحالة التلاعب بمحتواه بحيث يستطيع الجميع التأكد من أصالة البيان بسهولة.
و لنفترض أن الإخوة في مركز الفجر يرغبوا في إمضاء بيان قبل نشره. يكون الوضع كالتالي.

1- نضع البيان في نافذة "Message to be Signed "
2- ندخل كلمة السر التي تحمي المفتاح الخاص.
3- نضغط على "إمضاء". فيقوم البرنامج بحساب الإمضاء الرقمي في بضعة ثواني.

إمضاء أحد البيانات

4- بعد انتهاء البرنامج من عملية حساب الإمضاء الرقمي تظهر النافذة التالية حيث تظهر الرسالة و مرفق معها الإمضاء الرقمي.
5- نقوم بنسخ البيان مع الإمضاء الرقمي المرفق معه عن طريق الضغط على الزر "نسخ Copy" أو تخزين البيان عن طريق الضغط على "تخزين باسم Save as".

البيان بعد إمضاءه


11.2 فحص أصالة الرسالة المفتوحة

11.2 فحص أصالة الرسالة المفتوحة

إذا أراد شخص أن يتأكد من أن بيان معين هو من إصدار "مركز الفجر للإعلام" مثلا فانه يختار المفتاح العام لمركز الفجر و الذي يكون منشورا في المنتديات الموثوق بها. ثم يضغط على زر "إمضاء \ فحص". ثم إتباع الخطوات التالية:

1- نسخ الإمضاء الرقمي ووضعه في نافذة "RMSG Digital Signature " كما في الواجهة التالية.

فحص أصالة أحد البيانات

2- نسخ البيان ووضعه في النافذة التالية.
3- نضغط على الزر "فحص Verify"

فحص أصالة أحد البيانات

إذا كان البيان أصلي فان الرسالة التالية تظهر لنا.

رسالة تؤكد أصالة البيان

إذا لم يكن البيان أصلي أو تم تعديله و لو بحرف واحد فان الرسالة التالية تبين عدم أصالة البيان.

رسالة تؤكد عدم أصالة البيان


11.3 إمضاء الملفات المشفرة و المفتوحة

11.3 إمضاء الملفات المشفرة و المفتوحة

إذا أردنا أن نصدر إمضاءا رقميا لملف معين فإننا نتبع الخطوات التالية و ذلك بعد أن نكون اخترنا مفتاحنا الخاص الذي سوف يستخدم للإمضاء.

1- في نافذة "Sign and Verify Files " نقوم باختيار الملف الذي نرغب في إصدار إمضاء رقمي له.
2- نضغط على الزر "Sign File "

إمضاء أحد الملفات

3- تظهر نافذة تطلب منا كلمة السر لمفتاحنا الخاص. حيث يستخدم المفتاح الخاص لإمضاء البصمة الرقمية للملف.

إدخال جملة مرور المفتاح الخاص

بعد ذلك نحصل على رسالة (نافذة) تؤكد نجاح العملية. و يتم إنشاء ملف الإمضاء الرقمي و يكون بنفس اسم الملف بإضافة الامتداد ".sig". نقوم بعدها بنشر الملف المعني مرفق معه ملف الإمضاء الرقمي الذي يستخدم للتأكد من هوية المصدر. يمكننا هنا إمضاء أي نوع من الملفات بما فيها الملفات المشفرة و التي تكون بامتداد ".enc" كما يمكننا إمضاء الملف المشفر تلقائيا بعد تشفيره مباشرة. انظر الصورة التالية حيث يتم اختيار "Sign Encrypted File" و بعدها نضغط على زر التشفير.

إمضاء ملف آليا بعد تشفيره


11.4 فحص أصالة الملفات المشفرة المفتوحة

11.4 فحص أصالة الملفات المشفرة المفتوحة

إذا حصلنا على ملف مرفق بإمضاء رقمي للهيئة التي أصدرت الملف فاننا نتبع الخطوات التالية:

 1- نختار المفتاح العام للهيئة التي أصدرت الملف.
2- نذهب لنافذة فحص الإمضاء الرقمي.
3- نختار الملف المراد فحصه
4- نختار ملف الإمضاء الرقمي و يكون عادة بنفس اسم الملف مع زيادة الامتداد ".sig"
5- نضغط الزر "Verify File"

التأكد من أصالة أحد الملفات

بعد هذا تظهر أمامك رسالة تؤكد صحة الإمضاء و سلامة الملف.

تأكيد أصالة الملف

و إذا كان الملف غير أصلي فإن رسالة خطأ تظهر أمامك.


12. ملفات البرنامج

12. ملفات البرنامج

البرنامج مرفق بعدد من الملفات منها ما هو موجود مسبقا و منها ما يتم إنشاؤه تلقائيا:

1- ملف AsrarKeys.db : قاعدة بيانات مشفرة تحتوي على المفاتيح الفعالة بعد إدراجها في البرنامج.
الملف المرفق يحتوي على المفتاح العام لمجموعة الأمن التقني في شبكة الإخلاص الإسلامية.
إذا قمت بمسح هذا الملف فسوف يتم إنشاؤه تلقائيا بعد التشغيل و يكون فارغا حتى تقوم بإدراج المفاتيح بداخله.

2- ملف : asrar.ini ملف خيارات يتم إنشاؤه إذا قمت بتغيير الخيارات الافتراضية (default settings) و يتم حفظ الاختيارات الجديدة بداخله. إذا قمت بإلغائه يقوم البرنامج باستخدام الخيارات الافتراضية. عندما نقوم بتغيير الاختيارات و تحديد المفاتيح التي تستخدم في التراسل بالإضافة إلى خيارات تحويل الملفات إلى نصوص فإننا نقوم بضغط أيقونة حفظ الإعدادات في الواجهة الرئيسية [image] .

3- ملف المفتاح العام (publicXXXXXXXX.akf ) و ملف المفتاح الخاص (privateYYYYYYYY.akf) و هذان الملفان يتم إنشاؤهما بعد عملية إنتاج زوج مفتاح جديد (Key Pair). عند إدراج المفتاح الخاص بالبرنامج و نشر الملف العام تصبح هذه المفاتيح احتياطية. ليس ضروريا إدراج مفتاحك العام بداخل البرنامج لان المفتاح الخاص يحتوي على نسخة من المفتاح العام و مفتاحك العام يستخدمه مراسلك لتشفير الرسائل المرسلة إليك.
مرفق المفتاح العام لمجموعة الأمن التقني التي تقوم بتصنيع البرنامج و إمضائه رقميا. كما يمكن استخدام هذا المفتاح لمراسلة هذه المجموعة المفتاح تم إدراجه في قاعدة البيانات و الملف الموجود هو نسخة احتياطية فقط.public_Ekhlaas_TSG.akf

4- ملف المساعدة Asrar.chm

5- ملف الإمضاء الرقمي و الذي يستخدم مع المفتاح العام لمجموعة الأمن التقني للتأكد من أصالة البرنامج Asrar_2.exe.sig

لزيادة سرية الملفات يمكنك تغيير أسماء المفاتيح و البرنامج و وضعهم في مجلد نظام التشغيل و يفضل أن تضعهم في ذاكرة محمولة صغيرة الحجم (القياسات) محمية بكلمة سر يسهل تدميرها عند الحاجة.


13. خلاصة

13. خلاصة

برنامج "أسرار المجاهدين" هو تقنية عالية في التشفير يفوق المستويات المعمول بها عالميا في التشفير المتناظر و يوفر خاصية جديدة سميت بالتشفير الشبح باستخدام أفضل خمس خوارزميات في علم التشفير.
برنامج "أسرار المجاهدين" يحتوي على مزايا عديدة تجعله برنامج التشفير الوحيد الآمن للاستخدامات الجهادية و البرنامج مكون من ملف واحد لا يتطلب التثبيت على الحاسوب و يمكن تشغيله من ذاكرة محمولة كما يحتوي على خاصية المسح الآمن للملفات المصدر أو ما يسمى الإتلاف النهائي للملفات الأصلية حيث يستحيل استرجاعها و تضمن بذلك سرية ملفاتك بعد مسحها. كما يحتوي الإصدار الجديد على التراسل الفوري المشفر عبر الرسائل الخاصة بالمنتديات و خدمة تحويل الملفات بجميع أنواعها إلى نصوص يتم تبادلها عبر المنتديات. بالإضافة إلى الإمضاء الرقمي و الذي يؤكد الهوية الرقمية للشخص المرسل. البرنامج يوفر خدمة الإمضاء الرقمي للرسائل و الملفات و التأكد من هوية المصدر عن طريق فحص الإمضاء الرقمي و يمنع بذلك تزوير البيانات.

انتهى بحمد الله و توفيقه


14. أسـئـــلة شائعـــــة

14. أسـئـــلة شائعـــــة

1. ما الفرق بين البصمة الرقمية و الإمضاء الرقمي؟
البصمة الرقمية هي شيفرة رقمية بطول 160 بت، 256 بت أو حتى 512 بت و لكل ملف بصمته الرقمية التي لا يمكن تقليدها. و بالتالي يستحيل تصنيع ملفين بنفس البصمة الرقمية.
فإذا كانت عندك البصمة الرقمية لملف معين فإنك تستطيع في أي وقت معرفة إذا ما كان ملف ما هو نفسه الملف الأصلي أو أنه تم تعديله.
فالبصمة الرقمية هي هوية الرقمية للملفات.
أما الإمضاء الرقمي فهو عبارة عن البصمة الرقمية مشفرة بالمفتاح الخاص للهيئة أو الشخص الذي أصدر الملف و بالتالي فإن الإمضاء الرقمي لا يضمن فقط أصالة الملف و لكن يضمن لك أيضا مصدر الملف و أن ملفا معينا هو ملف أصيل و من المصدر الذي تمتلك أنت مفتاحه العام. و بالتالي فإن الإمضاء الرقمي يغني عن البصمة الرقمية.
2. ما الفرق بين التشفير المتناظر و التشفير اللامتناظر؟
التشفير المتناظر هو التشفير المستخدم في حماية الملفات على الحاسوب بحيث نستخدم نفس كلمة السر لتشفير الملفات و لفك تشفيرها و هذا النوع من التشفير قوي جدا و لكنه غير مناسب للاستخدام عبر الشبكات حيث لا يمكن تبادل كلمة السر أو ما يعرف بالمفتاح المشترك أو الخاص.
التشفير اللامتناظر أو التشفير بالمفتاح العام هو تقنية تسمح بتبادل الملفات و الرسائل المشفرة عبر الشبكات بحيث يتم تخصيص مفتاح للتشفير و مفتاح آخر لفك التشفير. المفتاح الخاص بالتشفير يعرف باسم المفتاح العام و يتم نشره في المنتديات أو عبر مزودات خاصة. ما يتم تشفيره بالمفتاح العام لا يمكن فك تشفيره إلا بالمفتاح الخاص. المفتاح الأول و الثاني يشكلان ما يعرف بزوج مفتاح. كل مستخدم للبرنامج يقوم بإنشاء زوج مفتاح و لا يتم نشر المفتاح الخاص بأية طريقة فلا ضرورة لذلك. المفتاح الخاص يتم تخزينه على جهاز الحاسوب بشكل مشفر فحتى لو تمت سرقته فلا يمكن استخدامه من دون جملة سرية خاصة.

3. ماذا يعني عمليا أن المفتاح بطول 2048 بت.
طول المفتاح هو سر قوة نظام التشفير. المفتاح بطول 2048 بت هو عبارة عن عدد أولي يزيد عن 3.2 ضرب 10 مرفوعة للقوة 616 مما يعني عدد مكون من 617 رقم. محاولة إيجاد مفتاح خاص لمفتاح عام منشور قد تستغرق عدد خرافي من السنوات بالاستعانة بأجهزة حواسيب متوازية فائقة السرعة. المفاتيح المعتمدة عالميا على مواقع الانترنت لحماية المعلومات الحساسة مثل التجارة الإلكترونية تعتمد على مفاتيح لامتناظرة بطول 1024 بت و مفاتيح متناظرة بطول 128 بت.المفاتيح المستخدمة في برنامج "أسرار المجاهدين" تفوق في قوتها المفاتيح المستخدمة المذكورة سابقا بملايين المرات و في الواقع تزيد عن هذا إلى أرقام خرافية.

4. ما الفرق بين الإمضاء الرقمي و التشفير
التشفير هدفه حماية المعلومات و نقلها بسرية تامة. بينما هدف الإمضاء الرقمي هو ضمان أن ملف أو رسالة معينة هي من المصدر الذي تعتقده.
الإمضاء الرقمي يستخدم أصلا لضمان عدم تعرض البيانات أو الملفات للتزوير. و هو الوسيلة الوحيدة لإثبات الهوية الرقمية.

5. هل هناك مخاطر في استخدام نفس المفتاح للإمضاء الرقمي و التشفير في نفس الوقت؟
المفتاح العام يستخدم للتشفير و لفحص الإمضاء الرقمي بينما يستخدم المفتاح الخاص لفك التشفير و إمضاء البيانات أو الملفات رقميا. و لضرورة أمنية إضافية يمكن تخصيص زوج مفتاح للتشفير و زوج مفتاح آخر للإمضاء الرقمي و لكن هذا ليس ضروريا في معظم الأحيان.

6. ما نوع الإمضاء الرقمي المستخدم في البرنامج؟
الإمضاء الرقمي يستخدم خوارزمية RSA بمفاتيح بطول 2048 بت.


تحذير أمني

تحذير أمني

إن أمن معلوماتك يتعلق بحسك الأمني و معرفتك بالأمور المتعلقة بأمن المعلومات و برامج التجسس فمهما كان البرنامج الذي تستخدمه قويا فإنه لا يغنيك عن أمور أخرى لا تقل أهمية بل ربما هي الأهم. فلا تستخدم جهاز لا تعرف صاحبه فبعض الأجهزة عليه برامج تجسس تسمى "Key Logger" تقوم بتسجيل كل ما تكتب و بعضها يقوم بتصوير الشاشة التي تعمل عليها و يرسلها لجهاز حاسوب عن بعد. ربما جلست في مقهى إنترنت تكتب رسالة سرية و اطمأننت أنه لا يوجد شخص خلفك ليرى ما تكتب و لكن انتبه إذا كان الجهاز "مُلَغما" بفيروس تجسسي (Spy Virus) من نوع حصان طروادة (Trojan Virus) فان صاحب المقهى يستطيع رؤية ما تكتب و يستطيع نسخ ملفاتك الموجودة على الجهاز و معرفة جميع أسرارك و سرقة مفاتيحك. لا تدخل على الانترنت إلا باستخدام مزود وكيل آمن (Secure proxy server) حتى تضمن أن تصفحك يستخدم قناة مشفرة. جميع برامجك يجب أن تكون محمولة Portable . كن حريصا أن تعمل على جهاز نظيف و محمي بجدار ناري و برنامج مضاد للفيروسات محدث و عند انتهاء عملك قم بتدمير (Shred) الملفات السرية و ليس فقط مسحها.

قال تعالى:

{وَأَعِدُّواْ لَهُم مَّا اسْتَطَعْتُم مِّن قُوَّةٍ وَمِن رِّبَاطِ الْخَيْلِ تُرْهِبُونَ بِهِ عَدْوَّ اللّهِ وَعَدُوَّكُمْ}

((شبكة الإخلاص الإسلامية))